Files @ 02d25dc028fc
Branch filter:

Location: ohnobinki_overlay/dev-libs/libstrl/libstrl-0.2-r1.ebuild

02d25dc028fc 638 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
dev-libs/tinygettext: Add tinygettext-0.1_pre20110220, which can have unstable keywords unlike the SVN ebuild.

(Portage version: 2.2.0_alpha24/hg/Linux i686, unsigned Manifest commit)
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="2"

inherit autotools-utils multilib

DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), and strnlen()"
HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
SRC_URI="ftp://mirror.calvin.edu/~binki/${P}.tar.bz2"

LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~amd64-linux ~x86"
IUSE="doc static-libs test"

DEPEND="doc? ( app-doc/doxygen )
	test? ( dev-libs/check )"
RDEPEND=""

src_configure() {
	myeconfargs=(
		$(use_with doc doxygen)
		$(use_with test check)
	)

	autotools-utils_src_configure
}