Files @ 078328bea2dd
Branch filter:

Location: ohnobinki_overlay/dev-php/phpcaptcha/phpcaptcha-2.0.1.ebuild

078328bea2dd 813 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
dev-lang/spidermonkey: Fix bug 325849 , fixing compilation on hardened and portage-multilib by replacing a call to $(LD) with a call to $(CC) and ensuring that CFLAGS and LDFLAGS are both respected.

(Portage version: 2.2.0_alpha11-r1/hg/Linux x86_64, signed Manifest commit with key 6BA81050)
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.9.ebuild,v 1.12 2009/11/04 12:12:05 arfrever Exp $

EAPI="2"

inherit eutils

DESCRIPTION="PHP captcha creator and validator library"
HOMEPAGE="http://phpcaptcha.org/"
SRC_URI="mirror://ohnoproto/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

S=${WORKDIR}

src_prepare() {
	epatch "${FILESDIR}"/${P}-pic.patch

	mkdir securimage-doc || die
	mv -v securimage/README* securimage-doc/ || die

	# it's good that the license is distributed, we just don't want to
	# install it below.
	rm -v securimage/LICENSE.txt || die
}

src_install()
{
	insinto /usr/share/php
	doins -r securimage || die

	dodoc securimage-doc/* || die
}