Files
@ 0a16ce99e697
Branch filter:
Location: ohnobinki_overlay/media-gfx/povray/povray-3.7.0_beta29-r1.ebuild
0a16ce99e697
3.3 KiB
application/vnd.gentoo.ebuild
bumped to media-gfx/povray-3.7.0_beta29-r1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 | # Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_beta25-r1.ebuild,v 1.3 2008/09/12 05:17:50 lavajoe Exp $
inherit eutils autotools flag-o-matic versionator
POVRAY_MAJOR_VER=$(get_version_component_range 1-3)
POVRAY_MINOR_VER=$(get_version_component_range 4)
if [ -n "$POVRAY_MINOR_VER" ]; then
POVRAY_MINOR_VER=${POVRAY_MINOR_VER/beta/beta.}
MY_PV="${POVRAY_MAJOR_VER}.${POVRAY_MINOR_VER}"
else
MY_PV=${POVRAY_MAJOR_VER}
fi
DESCRIPTION="The Persistence of Vision Raytracer"
HOMEPAGE="http://www.povray.org/"
SRC_URI="http://www.povray.org/beta/source/${PN}-src-${MY_PV}.tar.bz2"
LICENSE="povlegal-3.6"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="svga tiff X"
DEPEND="media-libs/libpng
tiff? ( >=media-libs/tiff-3.6.1 )
media-libs/jpeg
sys-libs/zlib
X? ( x11-libs/libXaw )
svga? ( media-libs/svgalib )
>=dev-libs/boost-1.33"
S="${WORKDIR}/${PN}-${MY_PV}"
src_unpack() {
unpack ${A}
cd "${S}"
# Remove POVRay's code that pointlessly aborts if the beta has ``expired''
epatch "${FILESDIR}"/${P}-remove-expiration.patch
# Change some destination directories that cannot be adjusted via configure
cp configure.ac configure.ac.orig
sed -i -e 's:${povsysconfdir}/$PACKAGE/$VERSION_BASE:${povsysconfdir}/'${PN}':g' configure.ac
sed -i -e 's:${povdatadir}/$PACKAGE-$VERSION_BASE:${povdatadir}/'${PN}':g' configure.ac
sed -i -e 's:${povdatadir}/doc/$PACKAGE-$VERSION_BASE:${povdatadir}/doc/'${PF}':g' configure.ac
cp Makefile.am Makefile.am.orig
sed -i -e "s:^povlibdir = .*:povlibdir = @datadir@/${PN}:" Makefile.am
sed -i -e "s:^povdocdir = .*:povdocdir = @datadir@/doc/${PF}:" Makefile.am
sed -i -e "s:^povconfdir = .*:povconfdir = @sysconfdir@/${PN}:" Makefile.am
# The "+p" option on the test command line causes a pause and
# prompts the user to interact, so remove it.
sed -i -e"s:biscuit.pov -f +d +p:biscuit.pov -f +d:" Makefile.am
eautoreconf
}
src_compile() {
# Fixes bug 71255
if [[ $(get-flag march) == k6-2 ]]; then
filter-flags -fomit-frame-pointer
fi
# The config files are installed correctly (e.g. povray.conf),
# but the code compiles using incorrect [default] paths
# (based on /usr/local...), so povray will not find the system
# config files without the following fix:
append-flags -DPOVLIBDIR=\\\"${ROOT}usr/share/${PN}\\\"
append-flags -DPOVCONFDIR=\\\"${ROOT}etc/${PN}\\\"
econf \
COMPILED_BY="Portage (Gentoo `uname`) on `hostname -f`" \
$(use_with svga) \
$(use_with tiff) \
$(use_with X) \
--disable-strip \
|| die
emake || die
}
src_install() {
emake DESTDIR="${D}" install || die
}
pkg_preinst() {
# Copy the old config files if they are in the old location
# but do not yet exist in the new location.
# This way, they can be treated by CONFIG_PROTECT as normal.
for conf_file in $(ls "${D}/etc/${PN}"); do
if [ ! -e "${ROOT}etc/${PN}/${conf_file}" ]; then
for version_dir in $(ls "${ROOT}etc/${PN}" | grep "^[0-9]" | sort -rn); do
if [ -e "${ROOT}etc/${PN}/${version_dir}/${conf_file}" ]; then
mv "${ROOT}etc/${PN}/${version_dir}/${conf_file}" "${ROOT}etc/${PN}"
elog "Note: ${conf_file} moved from ${ROOT}etc/povray/${version_dir}/ to ${ROOT}etc/povray/"
break
fi
done
fi
done
}
|