Files @ 2690ee09fa96
Branch filter:

Location: ohnobinki_overlay/dev-libs/libstrl/libstrl-0.2.ebuild

2690ee09fa96 798 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
dev-util/bin_replace_string: Remove bin_replace_string, in gentoo sunrise overlay.
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.9.ebuild,v 1.12 2009/11/04 12:12:05 arfrever Exp $

EAPI="2"

inherit base multilib

DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), and strnlen()"
HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
SRC_URI="ftp://mirror.calvin.edu/~binki/${P}.tar.bz2"

LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~amd64-linux"
IUSE="doc test"

DEPEND="doc? ( app-doc/doxygen )
	test? ( dev-libs/check )"
RDEPEND=""

src_configure() {
	econf \
		--docdir=/usr/share/doc/${PF} \
		$(use_with doc doxygen) \
		$(use_with test check)
}

src_install() {
	base_src_install

	rm -vf "${D}"/usr/$(get_libdir)/libstrl.la || die
}