Files
@ 27f754f75483
Branch filter:
Location: ohnobinki_overlay/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild
27f754f75483
3.1 KiB
application/vnd.gentoo.ebuild
x11-drivers/linuxwacom: Initial import from Gentoo's Portage
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 | # Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild,v 1.11 2009/12/10 08:05:10 zmedico Exp $
inherit eutils autotools toolchain-funcs linux-mod
DESCRIPTION="Input driver for Wacom tablets and drawing devices"
HOMEPAGE="http://linuxwacom.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P/_p/-}.tar.bz2"
IUSE="gtk tcl tk usb modules"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
COMMON_DEPEND="x11-proto/inputproto
<x11-base/xorg-server-1.7
gtk? ( >=x11-libs/gtk+-2 )
tcl? ( dev-lang/tcl )
tk? ( dev-lang/tk )
sys-fs/udev
sys-libs/ncurses"
RDEPEND="${COMMON_DEPEND}
!x11-drivers/xf86-input-wacom"
DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
usb? ( >=sys-kernel/linux-headers-2.6 )"
S=${WORKDIR}/${P/_p/-}
MODULE_NAMES="wacom(input:${S}/src:${S}/src)"
wacom_check() {
ebegin "Checking for wacom module"
linux_chkconfig_module TABLET_USB_WACOM
eend $?
if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
eerror "You need to have your kernel compiled with wacom as a module"
eerror "to let linuxwacom overwrite it."
eerror "Enable it in the kernel, found at:"
eerror
eerror " Device Drivers"
eerror " Input device support"
eerror " Tablets"
eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
eerror
eerror "(in the "USB support" page it is suggested to include also:"
eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
eerror
eerror "Then recompile kernel. Otherwise, remove the module USE flag."
die "Wacom not compiled in kernel as a module!"
fi
}
pkg_setup() {
if use modules; then
linux-mod_pkg_setup
wacom_check
# echo "kernel version is ${KV} , name is ${KV%%-*}"
fi
ewarn "Versions of linuxwacom >= 0.7.9 require gcc >= 4.2 to compile."
}
src_unpack() {
unpack ${A}
cd "${S}"
# Fix multilib-strict error for Tcl/Tk library install
sed -i -e "s:WCM_EXECDIR/lib:WCM_EXECDIR/$(get_libdir):" configure.in
# Remove warning parameters for gcc < 4, bug 205139
if [[ $(gcc-major-version) -lt 4 ]]; then
sed -i -e "s:-Wno-variadic-macros::" src/xdrv/Makefile.am
fi
eautoreconf
}
src_compile() {
if use modules; then
myconf="${myconf} --enable-wacom"
myconf="${myconf} --with-kernel=${KV_OUT_DIR}"
fi
econf ${myconf} \
$(use_with tcl tcl) \
$(use_with tk tk) \
--enable-wacomdrv --enable-wacdump \
--enable-xsetwacom --enable-dlloader || die "econf failed"
#$(use_enable quirks quirk-tablet-rescale) \
unset ARCH
emake || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" install || die "Install failed."
# Inelegant attempt to work around a nasty build system
if use modules; then
cp "${S}"/src/*/wacom.{o,ko} "${S}"/src/
linux-mod_src_install
fi
insinto /etc/udev/rules.d/
newins "${FILESDIR}"/${P%_p*}-xserver-xorg-input-wacom.udev 60-wacom.rules
exeinto /lib/udev/
doexe "${FILESDIR}"/check_driver
doman "${FILESDIR}"/check_driver.1
dohtml -r docs/*
dodoc AUTHORS ChangeLog NEWS README
}
|