Files @ 475bd1a361e8
Branch filter:

Location: ohnobinki_overlay/app-arch/lcab/lcab-1.0_beta12.ebuild

475bd1a361e8 602 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
bumped to dev-embedded/phidget-2.1.5.20090105, created new files/phidget21-crosscompile.patch for this version, updated logic in dev-embedded/phidget's ebuilds
logic was changed in the all of the ebuilds - they are all identical except for which patches are referenced. Fixed references to things like make=>emake and calling java stuff when the java use-flag was disabled. The new files/phidget21-crosscompile.patch (files/phidget21-2.1.5.20090105.patch) was needed because the context of the diff against the Makefile changed.
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: Exp $

inherit autotools

MY_PV="${PV/_beta/b}"

DESCRIPTION="CAB file creation tool"
HOMEPAGE="http://lcab.move-to-cork.com"
SRC_URI="http://lcab.move-to-cork.com/sources/${PN}-${MY_PV}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="virtual/libc"

S="${WORKDIR}/${PN}-${MY_PV}"

src_unpack() {
	unpack ${A}
	cd "${S}"
	sed -i "s:1.0b11:${MY_PV}:" mytypes.h
	eautoreconf || die
}

src_install() {
	make DESTDIR="${D}" install || die
	dodoc README COPYING
}