Files @ 475bd1a361e8
Branch filter:

Location: ohnobinki_overlay/app-pda/libopensync-plugin-sunbird/libopensync-plugin-sunbird-0.22.ebuild

475bd1a361e8 794 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
bumped to dev-embedded/phidget-2.1.5.20090105, created new files/phidget21-crosscompile.patch for this version, updated logic in dev-embedded/phidget's ebuilds
logic was changed in the all of the ebuilds - they are all identical except for which patches are referenced. Fixed references to things like make=>emake and calling java stuff when the java use-flag was disabled. The new files/phidget21-crosscompile.patch (files/phidget21-2.1.5.20090105.patch) was needed because the context of the diff against the Makefile changed.
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-sunbird/libopensync-plugin-sunbird-0.22.ebuild,v 1.2 2007/09/08 10:25:35 peper Exp $

inherit flag-o-matic

DESCRIPTION="OpenSync Sunbird Plugin"
HOMEPAGE="http://www.opensync.org/wiki/opensync-${PV}-notes"
SRC_URI="http://opensync.org/download/releases/${PV}/${P}.tar.bz2"

KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="LGPL-2.1"
IUSE=""

DEPEND="=app-pda/libopensync-${PV}*
	net-misc/neon"
RDEPEND="${DEPEND}"

src_compile() {
	append-flags -Wno-error
	econf || die "econf failed"
	emake || die "emake failed"
}

src_install() {
	emake DESTDIR="${D}" install || die "emake install failed"
	dodoc AUTHORS ChangeLog NEWS README
}