Files @ 504f418f14a3
Branch filter:

Location: ohnobinki_overlay/dev-util/difffilter/difffilter-0.1.ebuild

504f418f14a3 505 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
New ebuild dev-util/difffilter-0.1. A utility to filter the unwanted portions of unified diffs out of a patch.
(Portage version: 2.2_rc67-r8/hg/Linux x86_64)
(Signed Manifest commit)
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=2

inherit base

DESCRIPTION="Filter files out of unified diffs using POSIX extended regular expressions"
HOMEPAGE="http://ohnopub.net/~ohnobinki/difffilter/"
SRC_URI="ftp://ohnopub.net/mirror/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"

KEYWORDS="~amd64"
IUSE="doc"

RDEPEND="dev-libs/tre"
DEPEND="doc? ( app-text/txt2man )
	${RDEPEND}"

src_configure() {
	econf $(use_enable doc)
}