Files @ 51e241b2e8c5
Branch filter:

Location: ohnobinki_overlay/dev-games/supertux-editor/supertux-editor-9999.ebuild

51e241b2e8c5 756 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
merge
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=4

inherit eutils mono multilib subversion

DESCRIPTION="Level editor for supertux milestone 2"
HOMEPAGE="http://supertux.lethargik.org/wiki/Editor_FAQ"
ESVN_REPO_URI="http://supertux.lethargik.org/svn/supertux/trunk/supertux-editor"

LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS=""
IUSE=""

DEPEND="dev-lang/mono
	dev-dotnet/glade-sharp:2
	dev-dotnet/gtk-sharp:2"
RDEPEND="${DEPEND}
	=media-libs/libsdl-1.2*[opengl,X]
	media-libs/sdl-image[png]
	virtual/glu
	virtual/opengl"

src_install()
{
	insinto /usr/$(get_libdir)/${PN}
	doins *.{config,dll,exe} || die

	make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/supertux-editor.exe"
}