Files @ 6137caae8c77
Branch filter:

Location: ohnobinki_overlay/sys-apps/abi-wrapper/abi-wrapper-1.0-r3.ebuild

6137caae8c77 474 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
app-portage/sunrise-commit: Add ~x86 keyword.

(Portage version: 2.2.0_alpha12/hg/Linux i686, unsigned Manifest commit)
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

DESCRIPTION="Wraps binarys that behave abi dependand"
HOMEPAGE="www.gentoo.org"
SRC_URI=""

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64"
IUSE=""

src_unpack() {
	local abis="${DEFAULT_ABI} ${MULTILIB_ABIS/${DEFAULT_ABI}}"
	sed "s/@HARDCODED_ABIS@/${abis}/" "${FILESDIR}"/abi-wrapper > "${WORKDIR}"/abi-wrapper
}
src_install() {
	dobin abi-wrapper || die
}