Files
@ 64c0e8fe9914
Branch filter:
Location: ohnobinki_overlay/app-crypt/mit-krb5/mit-krb5-1.6.3-r6.ebuild
64c0e8fe9914
3.0 KiB
application/vnd.gentoo.ebuild
dev-libs/tinygettext: New ebuild for installable tinygettext for SuperTux
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 | # Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.6.3-r4.ebuild,v 1.9 2008/11/02 10:56:53 dertobi123 Exp $
EAPI="2"
inherit eutils flag-o-matic versionator autotools
PATCHV="0.5"
MY_P=${P/mit-}
P_DIR=$(get_version_component_range 1-2)
DESCRIPTION="MIT Kerberos V"
HOMEPAGE="http://web.mit.edu/kerberos/www/"
SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar
mirror://gentoo/${P}-patches-${PATCHV}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64"
IUSE="krb4 ldap tcl doc"
RDEPEND="!virtual/krb5
sys-libs/e2fsprogs-libs
sys-libs/db:3
ldap? ( net-nds/openldap )"
DEPEND="${RDEPEND}
doc? ( virtual/latex-base )"
S=${WORKDIR}/${MY_P}/src
PROVIDE="virtual/krb5"
src_unpack() {
unpack ${A}
unpack ./${MY_P}.tar.gz
}
src_prepare() {
EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"
epatch "${FILESDIR}/CVE-2009-0844+CVE-2009-0847.patch"
epatch "${FILESDIR}/CVE-2009-0846.patch"
einfo "Regenerating configure scripts (be patient)"
local subdir
for subdir in $(find . -name configure.in \
| xargs grep -l 'AC_CONFIG_SUBDIRS' \
| sed 's@/configure\.in$@@'); do
ebegin "Regenerating configure script in ${subdir}"
cd "${S}"/${subdir}
eautoconf --force -I "${S}"
eend $?
done
}
src_configure() {
# needed to work with sys-libs/e2fsprogs-libs <- should be removed!!
append-flags "-I/usr/include/et"
export DB_HEADER="db3/db_185.h"
export DB_LIB="-ldb-3"
econf \
$(use_with krb4) \
$(use_with ldap) \
$(use_with tcl) \
--enable-shared \
--with-system-et \
--with-system-ss \
--with-system-db \
--enable-dns-for-realm \
--enable-kdc-replay-cache || die
}
src_compile() {
emake -j1 || die
if use doc ; then
cd ../doc
for dir in api implement ; do
make -C "${dir}" || die
done
fi
}
src_test() {
einfo "Tests do not run in sandbox, have a lot of dependencies and are therefore completely disabled."
}
src_install() {
emake \
DESTDIR="${D}" \
EXAMPLEDIR=/usr/share/doc/${PF}/examples \
install || die
keepdir /var/lib/krb5kdc
cd ..
dodoc README
dodoc doc/*.ps
doinfo doc/*.info*
dohtml -r doc/*
use doc && dodoc doc/{api,implement}/*.ps
for i in {telnetd,ftpd} ; do
mv "${D}"/usr/share/man/man8/${i}.8 "${D}"/usr/share/man/man8/k${i}.8
mv "${D}"/usr/sbin/${i} "${D}"/usr/sbin/k${i}
done
for i in {rcp,rlogin,rsh,telnet,ftp} ; do
mv "${D}"/usr/share/man/man1/${i}.1 "${D}"/usr/share/man/man1/k${i}.1
mv "${D}"/usr/bin/${i} "${D}"/usr/bin/k${i}
done
newinitd "${FILESDIR}"/mit-krb5kadmind.initd mit-krb5kadmind
newinitd "${FILESDIR}"/mit-krb5kdc.initd mit-krb5kdc
newconfd "${FILESDIR}"/mit-krb5kdc.confd mit-krb5kdc
insinto /etc
newins "${D}/usr/share/doc/${PF}/examples/krb5.conf" krb5.conf.example
newins "${D}/usr/share/doc/${PF}/examples/kdc.conf" kdc.conf.example
insinto /etc/openldap/schema
use ldap && doins "${S}"/plugins/kdb/ldap/libkdb_ldap/kerberos.schema
}
pkg_postinst() {
elog "See /usr/share/doc/${PF}/html/krb5-admin.html for documentation."
}
|