Files @ 670f77a6d32b
Branch filter:

Location: ohnobinki_overlay/media-libs/libopenraw/libopenraw-0.0.8.ebuild

670f77a6d32b 1.0 KiB application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
dev-util/fastconf: Remove dev-util/fastconf which mgorny has killed and buried.
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/libopenraw/libopenraw-0.0.8.ebuild,v 1.12 2010/11/07 22:32:57 ssuominen Exp $

EAPI=2

inherit autotools

DESCRIPTION="Decoding library for RAW image formats"
HOMEPAGE="http://libopenraw.freedesktop.org"
SRC_URI="http://${PN}.freedesktop.org/download/${P}.tar.gz"

LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="gtk static-libs test"

RDEPEND="virtual/jpeg
	>=dev-libs/libxml2-2.5
	gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
	>=dev-libs/boost-1.35
	dev-util/pkgconfig
	sys-devel/boost-m4
	test? ( net-misc/curl )"

src_prepare() {
	# get the multilib-enabled boost.m4 from sys-devel/boost-m4
	rm -v m4/boost.m4 || die
	eautoreconf
}

src_configure() {
	econf \
		--disable-dependency-tracking \
		$(use_enable static-libs static) \
		$(use_enable gtk gnome)
}

src_install() {
	emake DESTDIR="${D}" install || die
	dodoc AUTHORS ChangeLog NEWS README TODO || die
}