Files @ 747bbbab5f5b
Branch filter:

Location: ohnobinki_overlay/x11-misc/xorg-cf-files/xorg-cf-files-1.0.3.ebuild

747bbbab5f5b 829 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
x11-misc/xorg-cf-files: Fix for bug 343461 which fixes a compile error in media-gfx/transfig. Upgrade to EAPI=2 and make ebuild prettier and more fail-fast.

(Portage version: 2.2.0_alpha2-r1/hg/Linux x86_64, signed Manifest commit with key 6BA81050)
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/xorg-cf-files/xorg-cf-files-1.0.3.ebuild,v 1.9 2010/01/19 20:28:54 armin76 Exp $

# Must be before x-modular eclass is inherited
# SNAPSHOT="yes"

EAPI=2

inherit eutils multilib x-modular

DESCRIPTION="Old Imake-related build files"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""

RDEPEND=""
DEPEND="${RDEPEND}"

src_prepare() {
	epatch "${FILESDIR}"/${P}-libdir.patch

	sed -i \
		-e "s/LibDirName *lib\$/LibDirName $(get_libdir)/" \
		Imake.tmpl || die "failed LibDirName sed"
}

src_install() {
	x-modular_src_install
	echo "#define ManDirectoryRoot /usr/share/man" >> ${D}/usr/$(get_libdir)/X11/config/host.def || die
}