Files @ 7b51f8bc6d6f
Branch filter:

Location: ohnobinki_overlay/sys-apps/kexec-tools/kexec-tools-2.0.1.ebuild

7b51f8bc6d6f 1.1 KiB application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
dev-games/supertux-editor: Fix accidental tarballing up an uncommitted supertux-editor patch. Also, add supertux:1 as an RDEPEND of supertux-editor since the data files are needed.

(Portage version: 2.2.0_alpha24/hg/Linux i686, unsigned Manifest commit)
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-2.0.1.ebuild,v 1.1 2010/01/10 09:57:10 robbat2 Exp $

EAPI=2

inherit eutils

DESCRIPTION="Load another kernel from the currently executing Linux kernel"
HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools"
SRC_URI="mirror://kernel/linux/kernel/people/horms/kexec-tools/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="xen zlib"
DEPEND="zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"

src_prepare() {
	# merged upstream
	#epatch "${FILESDIR}/${PN}-2.0.0-asneeded.patch"

	epatch "${FILESDIR}/${PN}-2.0.0-respect-LDFLAGS.patch"
}

src_configure() {
	# GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
	export ASFLAGS="${CCASFLAGS}"

	econf $(use_with zlib) $(use_with xen)
}

src_install() {
	emake DESTDIR="${D}" install || die "emake install failed"

	doman kexec/kexec.8
	dodoc News AUTHORS TODO

	newinitd "${FILESDIR}"/kexec.init kexec || die
	newconfd "${FILESDIR}"/kexec.conf kexec || die
}