Files @ 91eaead77c75
Branch filter:

Location: ohnobinki_overlay/media-libs/libdvdnav/libdvdnav-9999.ebuild

91eaead77c75 989 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
net-irc/unrealircd: changed dep on curl[ares,-ipv6] to curl
The ebuild had previously incorrectly carried a message saying that unrealircd required a copy of curl with ares built in and that curl's ipv6 useflag disables it's ares useflag even if portage records curl's cares flag as being set. The latter is true, but unrealircd runs fine with a copy of curl that is compiled without cares (which equals c-ares).
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

WANT_AUTOCONF="2.5"


inherit eutils autotools multilib subversion

DESCRIPTION="Library for DVD navigation tools"
HOMEPAGE="http://mplayerhq.hu/"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
IUSE="debug"

ESVN_REPO_URI="svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav"
ESVN_PROJECT="libdvdnav"

PROVIDE="media-libs/libdvdread"

src_compile() {
	./configure2 --prefix=/usr --libdir=/usr/$(get_libdir) \
		--shlibdir=/usr/$(get_libdir) --enable-static --enable-shared \
		--disable-strip --disable-opts \
		--extra-cflags=${CFLAGS} $(use_enable debug) || die "configure2 died"
	emake version.h && emake || die "emake version.h died"
	emake || die "emake died"
}

src_install () {
	emake -j1 DESTDIR="${D}" install || die "emake install died"
	dodoc AUTHORS DEVELOPMENT-POLICY.txt ChangeLog TODO \
		doc/dvd_structures
}