Files @ 91eaead77c75
Branch filter:

Location: ohnobinki_overlay/media-libs/sdl-image/sdl-image-1.2.6-r1.ebuild

91eaead77c75 1.5 KiB application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
net-irc/unrealircd: changed dep on curl[ares,-ipv6] to curl
The ebuild had previously incorrectly carried a message saying that unrealircd required a copy of curl with ares built in and that curl's ipv6 useflag disables it's ares useflag even if portage records curl's cares flag as being set. The latter is true, but unrealircd runs fine with a copy of curl that is compiled without cares (which equals c-ares).
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.6-r1.ebuild,v 1.2 2008/01/29 21:55:55 grobian Exp $

inherit eutils autotools libtool flag-o-matic pkgconfig

MY_P="${P/sdl-/SDL_}"
DESCRIPTION="image file loading library"
HOMEPAGE="http://www.libsdl.org/projects/SDL_image/index.html"
SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="gif jpeg tiff png"

DEPEND="sys-libs/zlib
	>=media-libs/libsdl-1.2.10
	png? ( >=media-libs/libpng-1.2.1 )
	jpeg? ( >=media-libs/jpeg-6b )
	tiff? ( media-libs/tiff )"

S=${WORKDIR}/${MY_P}

src_unpack() {
	unpack ${A}
	cd "${S}"
	epatch "${FILESDIR}/${P}-DOS.patch"
	epatch "${FILESDIR}/${PN}-crosspkgconfig.patch"
	epatch "${FILESDIR}/${PN}-crosspkgconfig_makefile.patch"
	cp "${FILESDIR}/${PN}.pc.in" ./
	elibtoolize
	eautoreconf
}

src_compile() {
	myconf = ""
	if [ "${CHOST}" != "${CBUILD}" ]; then
		myconf="--with-sdl-prefix=/usr/${CHOST} \
"
	fi
		econf \
		$(use_enable gif) \
		$(use_enable jpeg jpg) \
		$(use_enable tiff tif) \
		$(use_enable png) \
		$(use_enable png pnm) \
		--enable-bmp \
		--enable-lbm \
		--enable-pcx \
		--enable-tga \
		--enable-xcf \
		--enable-xpm \
		${myconf} \
			|| die
	emake || die "emake failed"
}

src_install() {
	emake DESTDIR="${D}" install || die "make install failed"
	dobin .libs/showimage || die "dobin failed"
	dodoc CHANGES README
}