Files @ 9b3f094be47a
Branch filter:

Location: ohnobinki_overlay/dev-util/jsmin/jsmin-20080803.ebuild

9b3f094be47a 551 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
sys-devel/gcc-config: Import gcc-config-1.4.1 and gcc-config-1.5 for fixing bug 351384.

(Portage version: 2.2.0_alpha11-r1/hg/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 6BA81050)
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=2

inherit toolchain-funcs

DESCRIPTION="A simple and lightweight JavaScript minifier"
HOMEPAGE="http://crockford.com/javascript/jsmin.html"
SRC_URI="ftp://ohnopub.net/mirror/${P}.c"
LICENSE="as-is"

SLOT="0"
KEYWORDS="~amd64 ~amd64-linux"
IUSE=""

S=${WORKDIR}

src_unpack() { :; }

src_compile() {
		$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${P}.c || die
}

src_install() {
		dobin ${PN} || die
}