Files @ a1377a397d21
Branch filter:

Location: ohnobinki_overlay/sci-calculators/gfm/gfm-1.02.ebuild

a1377a397d21 826 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
updated povray-3.7.0_beta28.ebuild with official Gentoo povray-3.7.0_beta29.ebuild
ignored syncing stuff specific to POVRay's expiration code: my repo has a patch which disables the pointless expiration - I mean, if ur running Gentoo, ur going to try to upgrade your POVRay b4 filing bugs :-)
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $


inherit qt3

DESCRIPTION="Program allowing a PC to communicate with a TI calculator."
HOMEPAGE="http://lpg.ticalc.org/prj_tilp"
SRC_URI="ftp://ohnopublishing.homelinux.net/distfiles/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE="kde xinerama"

RDEPEND=">=sci-calculators/tilp2-1.10
	>=x11-libs/gtk+-2.6.0
	>=dev-libs/glib-2.6.0
	>=gnome-base/libglade-2
	kde? ( kde-base/kdelibs:3.5 )
	xinerama? ( x11-libs/libXinerama )"
	
DEPEND="${RDEPEND}
	xinerama? (x11-libs/xineramaproto)"

src_compile() {
	econf \
		$(use_with kde) \
		$(use_with xinerama) \
		|| die "econf failed"
	emake || die "emake failed"
}

src_install() {
	emake install DESTDIR="${D}" || die "emake install failed"
}