Files @ a2381dd3d28a
Branch filter:

Location: ohnobinki_overlay/sys-apps/abi-wrapper/abi-wrapper-1.0-r2.ebuild

a2381dd3d28a 488 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
sys-apps/abi-wrapper: Import abi-wrapper-1.0-r2 from multilib overlay.

(Portage version: 2.2.0_alpha2-r1/hg/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 6BA81050)
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

DESCRIPTION="Wraps binarys that behave abi dependand"
HOMEPAGE="www.gentoo.org"
SRC_URI=""

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64"
IUSE=""

src_unpack() {
	local abis="${DEFAULT_ABI} ${MULTILIB_ABIS/${DEFAULT_ABI}}"
	sed "s/PLACEHOLDER_FOR_HARDCODED_ABIS/${abis}/" "${FILESDIR}"/abi-wrapper > "${WORKDIR}"/abi-wrapper
}
src_install() {
	dobin abi-wrapper || die
}