Files @ a3d160590220
Branch filter:

Location: ohnobinki_overlay/dev-games/supertux-editor/supertux-editor-0.3_pre20110221.ebuild

a3d160590220 862 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
media-plugins/live: Bump patched ebuild to live-2011.01.24.

(Portage version: 2.2.0_alpha23-r1/hg/Linux x86_64, signed Manifest commit with key 6BA81050)
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=4

inherit eutils mono multilib

DESCRIPTION="Level editor for supertux milestone 2"
HOMEPAGE="http://supertux.lethargik.org/wiki/Editor_FAQ"
SRC_URI="ftp://ohnopub.net/mirror/${P}.tar.bz2
	http://protofusion.org/mirror/${P}.tar.bz2"

LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="dev-lang/mono
	dev-dotnet/glade-sharp:2
	dev-dotnet/gtk-sharp:2"
RDEPEND="${DEPEND}
	games-arcade/supertux:1
	=media-libs/libsdl-1.2*[opengl,X]
	media-libs/sdl-image[png]
	virtual/glu
	virtual/opengl"

src_prepare()
{
	# ask the Makefile to be louder
	export VERBOSE=1
}

src_install()
{
	insinto /usr/$(get_libdir)/${PN}
	doins *.{config,dll,exe} || die

	make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/supertux-editor.exe"
}