Files @ a3d160590220
Branch filter:

Location: ohnobinki_overlay/sys-libs/libixp/libixp-0.5-r1.ebuild

a3d160590220 788 B application/vnd.gentoo.ebuild Show Annotation Show as Raw Download as Raw
binki
media-plugins/live: Bump patched ebuild to live-2011.01.24.

(Portage version: 2.2.0_alpha23-r1/hg/Linux x86_64, signed Manifest commit with key 6BA81050)
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/libixp-0.5.ebuild,v 1.1 2009/07/11 11:12:37 omp Exp $

EAPI=2

inherit multilib

DESCRIPTION="Standalone client/server 9P library"
HOMEPAGE="http://libs.suckless.org/libixp"
SRC_URI="http://code.suckless.org/dl/libs/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""

DEPEND=""
RDEPEND=""

src_prepare() {
	sed -i \
		-e "/^PREFIX/s|=.*|= ${D}/usr|" \
		-e "/^  ETC/s|=.*|= ${D}/etc|" \
		-e "/^CFLAGS/s|=|+=|" \
		-e "/^LDFLAGS/s|=|+=|" \
		-e "/LIBDIR =/s|/lib|/$(get_libdir)|" \
		config.mk || die "sed failed"
}

src_compile() {
	emake -j1 || die
}

src_install() {
	emake -j1 DESTDIR="${D}" install
}